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3SL Newsletters

Welcome to the 5th in the series of monthly newsletters from 3SL!

These newsletters will provide information on 3SL products and services, and on general requirements management and systems engineering topics.

For a formatted version of this newsletter, including screenshots, click here.

New Website

We would like to thank you for the positive feedback on our website, with Cradle descriptions, topics, manuals, downloads, its reference and on-line support.

From now on, the easiest way to get the latest Cradle software is: download it!
Visit www.threesl.com and create your login account now!

· If you need help creating a login account, or want more information, click here
· To be nominated as a Cradle customer, create your account, then e-mail 3SL support by clicking here, and be sure to tell us your login username

· To be nominated as a Cradle site representative, create your account, e-mail 3SL support by clicking here, and be sure to tell us your login username

Need Help?

If you have any problems with your Cradle system or evaluation we want to hear from you! E-mail our support team by clicking here.

We can offer support direct to your desktop through a webinar, all you need is a PC with a web browser and Internet access.

If you’ve a problem, we can display one of our Cradle systems directly onto your desktop, or yours onto ours (if you allow it). You can then show us the problem by driving this Cradle system, and we’ll show you how to fix it!

We can set up these webinars instantly, at any time, so please don’t struggle with a problem, get in touch with us and we can solve it together!

AP233 TBRs

There has been an international effort within the STEP programme to produce a common data exchange standard for product data, now defined in ISO10303. Within this work, there has been an on-going activity to standardise the format of systems engineering data, documented in specific Application Protocols (APs).  AP233 in particular has been evolved to specify a usage of the overall STEP data exchange format for the exchange of text based requirements (TBRs).

3SL is pleased to announce that we have been involved in this activity, and have incorporated AP233 format data exchange into Cradle.

The increasing adoption of AP233 and related parts of STEP in the systems engineering community will provide users with greater freedom to move systems engineering data between tools, and thereby will allow users to be ever less dependent on specific products from specific vendors.

3SL fully endorses this initiative, and is committed to the support of systems engineering APs in Cradle.

If you are interested in AP233 data exchange, please contact us by clicking here.

Dates and Paper Sizes

To ensure that US customers have correct default date formats and paper sizes, you should ensure that either the Cradle system preferences or your personal preferences have the correct settings.

Personal Preferences

In toolset;

· Select File→Options→Miscellaneous and set DATE FORMAT to US and select OK
Select File→Options→Graphics Printing and select Print Format Options and set PAPER SIZE to Letter and select OK in both dialogues

· Select File→Options→Text Printing and select Print Format Options and set PAPER SIZE to Letter and select OK and select Write… and select OK in both dialogues

System Preferences

The system preferences are held in the directory tree where Cradle has been installed. For Windows users, this is typically:

C:\Program Files\Cradle\bin\exe\win32pc\cradle.ini

And for UNIX users, it is a pathname of the form:

…Cradle install directory../bin/exe/…architecture…/.cradlerc
Edit this file and set the following attributes to the values shown:

DATES_US    = true

GPRINT_SIZE = letter

TPRINT_SIZE = letter
Controlling Lists

Cradle databases can contain very large numbers of items. When you browse the database or run queries to find items in the database, there could be thousands, or tens of thousands, of items that could be listed.

Cradle does not make you wait whilst all of these items appear, nor does Cradle overload the memory of your PC or workstation with thousands of items that you might never even look at.

So, Cradle always retrieves items from the database in blocks. You can control:

· The maximum number of items in each block

· Whether the block contains all items that exist (even if you cannot access them) or just the items that you can access

You can move through the database, retrieving new blocks of data, no matter how many items exist. You can do this either by reaching the end of the block and moving forwards (or the start of the block and moving backwards), or explicitly by selecting Next… and Previous… controls (such as you will see at the top and bottom of all lists, tables and trees in WorkBench).

You can control the size of these blocks in the range 100 to 8,000 items. The default is 200 items. In WorkBench:

· Select File→Options and set Max List Items to your desired value

· Select OK
In toolset:

· Select Tools→Customise→UI Control
· Select List Control and set Size of item queries to PDB to your desired value

Select OK in both dialogues, or to make the change permanent, select OK and then select Write… and select OK in both dialogues

To control whether lists in toolset show all items (even if you cannot access them) or just items that you can access, you can either define your queries appropriately or configure the list display itself. To do this:

Select Tools→Customise→UI Control
· Select List Control and set CONTENTS to your desired value

· Select OK in both dialogues, or to make the change permanent, select OK and then select Write… and select OK in both dialogues 

Cross Referenced Item Tables

Cradle WorkBench has a simple and powerful mechanism for producing tables. It can produce tables that show any view on a set of items, and more complex inter-relationships between items.

All tables start by running a query, to find those items that match the query’s search criteria. Each item found forms a row in the table. Next, a view is chosen to specify which attributes of these items are to be shown as the table’s columns.

Tables can also show cross referenced items, such as the functions linked to a requirement, or the acceptance criteria for a subsystem. The cross referenced items are shown as nested rows embedded inside the row for the main item. 

You can extend the cross referencing to any depth, for example to show the tests for each function that satisfies each system requirement. You can also have any amount of cross referencing, each to any depth, in a table. This is very powerful, since most key systems engineering deliverables are tables of cross referenced items, including:

· Requirements Traceability Matrix (RTM)

· Performance Verification Matrix (PVM)

· Verification Cross Reference Matrix (VCRM)

Such tables can be exported to Word, Excel and web browsers.

There are four steps to defining cross referenced item tables:

9. Specify the type(s) of items to be reported

10. Specify which cross references to use to find cross referenced items

11. Specify which attributes of the cross referenced items are to be shown

12. Specify whether, and which, attributes of the cross references between the items are to appear in the table

To show cross referenced items in a view, right click, choose View Details… from the popup menu and add a new column whose Data: element is LINKED_ITEMS. All of the attributes (that you will choose later) for the cross referenced items will be shown within this column, so choose a suitable column heading and enter it in the Name: field.

You have several choices when deciding which cross referenced items to show in the table. The most basic choice is between:

13. All linked items

14. Cross referenced items

15. Pseudo cross referenced items

There are secondary choices for each option, described in the sections below. To choose one of these alternatives, make a choice from the options presented in the Value: part of your new column definition.

All Linked Items

Use this option if you want to show basic details of all items that are linked to the given item in a single set of columns, irrespective of the type of linked item. That is, if you want details of all items of all types linked to a given item to be shown in a single set of columns, choose this option.

Selecting this option will cause WorkBench to find all items of all types that are linked to the given item. Since there can be many types of item, when you choose which attributes to show, you will only be able to choose from generic views.

Cross Referenced Items

Use this option if you want to show details of items that are linked to the given item by a particular set of cross references. You will choose a specific type of item and a specific navigation to select which cross referenced items will be shown.

You specify which type of cross referenced items are to be shown in this column by choosing from the item types listed in the To Type: field. You can then choose a navigation from the choices presented in the Navigation: field to select the items of this type.

These two fields work in combination. The To Type: field is used to select the type of cross referenced items that you want to show. Then, the navigation selected in the Navigation: field acts as a filter on the cross references to/from items of this type. The navigation selects which cross references to/from the given item to/from items of the chosen type will be followed. You could use the navigation, for example, to only follow cross references downwards (to items of your chosen type), or to only follow cross references upwards (from items of your chosen type), or to only use cross references of a specific type, or to only use cross references whose Notes attribute contains either Agreed or Pending, or any combination of these alternatives. The details of the selections to be used to decide which cross references to/from the given item will be used (to find cross referenced items to be shown in the view) is all made in the navigation. Here we are simply selecting a navigation, so you must have set up the navigation first to make the kind of selections that you want to see.

Pseudo Cross References

Cradle provides special kinds of relationships between diagrams and the definitions of diagram symbols, the specifications and Data Dictionary entries (DD entries).

Cross references are actual records in the database. Each cross reference must be created explicitly between a pair of items. Each cross reference applies to all instances of the items that it links (all versions and drafts). Cross references can have a type and can contain data in their attributes.

In contrast, pseudo cross references are not explicitly created. They arise due to the contents of the other items. That is, simply by including a symbol in a diagram, a pseudo cross reference will be created between that diagram symbol and its associated definition (specification or DD entry).

Thus pseudo cross references arise automatically as a result of the contents of items, and not by making explicit links between them.

Pseudo cross references are specific to instances of items. Thus each version of a DD entry has its own pseudo cross references to parent and child DD entries. This is because each version of a DD entry can have a different data composition to the other versions. Similarly, each version of an event can have its own set of relationships to other events. Similarly, each version of a diagram contains a different set of symbols to the other versions of that diagram, and so has its own set of pseudo cross references to the specifications and DD entries for the symbols in that diagram.

Only diagrams, DD entries and specifications have pseudo cross references, so you only have the chance to choose them if you are producing a cross referenced item view or table for these types of item. If you are, then the applicable types of pseudo cross references will appear in the choices presented for the Value: field when you are defining the view. These options include:

· Input and output DD entries

· Input DD entries

· Output DD entries

· Diagrams containing spec

· Diagrams referencing spec

· Diagrams equivalent to spec

· Parent DD entries

· Child DD entries

· Diagrams containing DD entry

· Source and destination specs

· Source specifications

· Destination specifications

· DD entries for diagram symbols

· Specs for diagram symbols

· Specs referenced by diagram symbols

· Spec equivalent to diagram

Since these are all pseudo cross references, we are not dealing with cross references in the database, and so there is no filtering of cross references, and so the Navigation: field is greyed-out.

Attributes of the Cross Referenced Items

You have chosen which cross referenced items are to be shown in the new column in your table, and you now need to choose which attributes of these items are to appear. This is very simple, simply choose a suitable view from the views presented in the View: field. This field will list either:

· All views defined for the type of cross referenced item that you have chosen

· All generic views, if you have chosen All Linked Items
You can choose any view from these lists.

If the view that you choose contains one or more columns containing LINKED_ITEMS, then your view will contain not only the attributes for your cross referenced items, but also the appropriate attributes for the items that are cross referenced to them. This will create a view that shows many levels of cross referenced item.

This facility is extremely powerful. It means that you can create very complex views that show many levels of cross referenced item, simply by referencing views that have progressively more and more levels of cross referenced items specified within them.

So, if, for example, you want a view that shows details of the tests for each function for each requirement, then you would create:

16. A view T of the details of tests

17. A view F of the details of functions that includes a column which specifies cross referenced tests displayed with view T

18. A view R of the details of requirements that includes a column which specifies cross referenced functions displayed with view F

When you look at the requirements through view R, you will see the details of each requirement, and a column that contains the details of the associated functions displayed with view F, and for each function, the details of the associated tests displayed with view T.

This process can continue to show more levels of cross reference items.

Showing Cross Reference Attributes

Most projects’ processes will include processes for creating links between items, and then justifying these links. This is very common between user and system requirements. Because Cradle allows you to store data inside cross references, it is common to store these justifications inside the cross reference attributes.

In turn, this means that you need to be able to print these attributes inside your views.

This is very easy. In the view of the cross referenced items, simply add a column and set its Data: field to contain one of the values:

· REASON, for the cross references’ Reason attribute

· RATIONALE, for the cross references’ Rationale attribute

· REFERENCE, for the cross references’ Reference attribute

· NOTE, for the cross references’ Note attribute

This means that it is easy to create a view that shows items, the items that are cross referenced to them, and the justification for these cross references.

Roles

Cradle provides a roles mechanism to assist projects to define user accounts quickly and consistently.

A project can define any number of roles, each is simply a name for a collection of user profile attributes, and in particular a set of user privileges. You can create any number of roles. They are stored in the project database, and are imported and exported with the user profiles. Each role has a unique name.

When you are creating a new user profile, you can base it on a specified role. This simply means that the user profile being created is initialised with all of the settings (privileges, skills, tool access rights and so on) that have been defined in the role. Once you have applied a role to the new user profile, you can make any further changes to it that you wish.

That is, applying a role does not irrevocably set the contents of a user profile, it is simply a convenient and quick method for setting up the contents of a user profile to a set of known values that you may change later.

You can apply roles by choosing them from the Based On: fields in the User Setup tools in both the Cradle toolset and WorkBench.

To define a role, you simply start the User Setup tool in either Cradle toolset or WorkBench and define whatever contents you want for the role, then select the Save Role… button and choose a name for the role. If you choose the same name as an existing role, it will be over-written with your new definition.
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